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Overview 
Purpose of the Quick Start Guide 

This Quick Start Guide provides basic information for customers on accessing and working with the Product 
Performance Reports.  This document is organized in a Frequently Asked Questions (FAQ) format, so that users 
will be able to quickly begin accessing and using the data contained within the reports. 

For more detailed information on these reports, refer to the Product Performance Reports User Guide (External). 

Product Performance Reports Background 

Product Performance Reports provide service and delivery performance information.  These reports provide 
information regarding acceptance, receipt, processing and delivery of mail in the Postal distribution and delivery 
networks.  The reports are available to both participating customers and internal Postal users, providing a common 
view of performance.  

Enterprise Data Warehouse Overview 

The United States Postal Service (USPS) Enterprise Data Warehouse (EDW) provides a single repository for 
managing all of the Postal Service’s data assets for reporting and analysis.  The EDW provides a single source of 
accurate data across organizations to a wide variety of users.  The data can be manipulated in a variety of ways, 
both within and across functions.   

Product Performance Reports available in the EDW allow drilling and provide greater flexibility to select range of 
dates and day of week for report results.  This deeper analysis can lead to additional revenue and improved 
business practices. 

MicroStrategy Reporting Tool Overview 

MicroStrategy is the reporting tool used to display and manipulate the Mail Tracking and Reporting (MT&R) data 
stored in the EDW.  MicroStrategy software enables users to query and analyze detailed, transaction-level 
databases, turning data into business intelligence and delivering reports and alerts about the users’ business 
processes.  MicroStrategy Web is the front-end portion of the Reporting software, which provides users with a 
highly interactive environment for building and analyzing reports. 
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How Do I Access Reports? 
New Users:  Request Access through Mail Tracking & Reporting 

If you do not already have access to the Product Performance Reports, you will need to request it through the 
Mail Tracking & Reporting (MT&R) website.  To request access complete the following steps: 

1. Navigate to MT&R by entering the following URL into your browser window: 
https://mailtracking.usps.com. 

2. The MT&R landing page displays.  Click on Product Performance. 
3. The Product Performance Report Landing page displays.  Click on Apply for Product Performance 
4. The Apply for Product Performance Reports page displays.  Click Sign Up under New Users. 
 

 
 
5. Enter New User Sign up information and click Continue. 
6. Enter User Profile information and click Continue. 
7. Review the User Profile Summary information and edit if necessary (using the Edit button) or click 

Continue. 
8. Search for company by entering your company name and clicking the Search button.   
9. If your company name does appear, select the company.  If you do not see your company, click on Add 

Company and enter company information. 
10. Search for a company address and click on Select This Address if company address exists.  If company 

address does not exist, add a company address by clicking Add Address. 
11. Review Company Information and edit if necessary using the Back button or click Submit Request.   
12. A confirmation screen noting your request has been sent will display. 
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Note: Registration does not give immediate access.  An administrator will contact you to begin the approval 
process.   

If you do not hear from the administrator, or have questions about the registration process, please contact 
Customer Support at 1-800-238-3150 (Mon – Fri 7:00 AM – 5:00 PM Central) or incsc@usps.gov. 
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Existing Users:  Access Product Performance Reports 

To access Product Performance Reports, complete the following steps: 
 

1. Navigate to MT&R by entering the following URL into your browser window:  https://mailtracking.usps.com.  
2. The MT&R landing page displays.  Click on Product Performance. 
3. The Product Performance Landing page displays.  Click on Apply for Product Performance.  
4. The Product Performance Report page displays.  Click Sign In under Existing Users. 
5. Enter your username and password and click Sign In. 

 

 
 

6. Upon logging into the MT&R site the MT&R Welcome Page displays.  Click on Product Performance. l 
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7. The EDW screen displays as shown below.  Click on the Product Performance Reporting link to access the 

reports. 
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What Shared Reports are Available?  
The following types of reports are available within the Shared Reports folder: 
 

Delivery Success (Customer Data) 
This delivery report monitors USPS and mail recipient behavior by showing how quickly “left notice” items are 
picked up.  This report provides details to the 5-digit ZIP level of total pieces scanned, pieces delivered on the first 
attempt, days between attempt and delivery by day, unclaimed, and pieces with no delivery or return scan.  

 

Cumulative Delivery Success (Customer Data) 

The Cumulative Delivery Success report contains attributes similar to the Delivery Success report except that data 
in each day’s column includes the pieces redelivered/picked up in the previous days. 

An example of the Delivery Success (Customer Data) report is shown below: 
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Days to Deliver (Customer Data) 

This service performance report provides service information from originating location by on time percentage and 
percentage delivered by day.  This report provides details on volume, volume within standard and volume delivered 
by day. 

 

Cumulative Days to Deliver (Customer Data) 

The Cumulative Days to Deliver (Customer Data) report contains attributes similar to the Days to Deliver (Customer 
Data) except that the data in each day’s column includes the pieces delivered in the previous days. 

An example of the Days to Deliver (Customer Data) report is shown below: 
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Days to Deliver – Parcel Select (Customer Data) 

This service performance report provides service information for Parcel Select by on time percentage and 
percentage delivered by day.  It allows a user to gain an understanding of performance by service standard within 
their location and see how many days it took to deliver.  

 

Cumulative Days to Deliver – Parcel Select (Customer Data) 

The Cumulative Days to Deliver – Parcel Select (Customer Data) report contains attributes similar to the Days to 
Deliver – Parcel Select (Customer Data) report except that the data in each day’s column includes the pieces 
delivered in the previous days. 

An example of the Days to Deliver – Parcel Select (Customer Data) report is shown below.  Though not shown, this 
report continues up to 8 or more days.  

 
 

 

 

 

 



Product Performance Report Quick Start Guide (External) Page 9 
 

How Do I Generate Reports? 
Generate Created Reports 

The Shared Reports folder contains the Product Performance Reports.  To run a report, follow these steps: 

1. Click on the Shared Reports folder.   

2. Click the name of the report.  The report begins executing and the wait page opens.  When the report is 
done executing, the selection prompts will appear.  

3. Identify selection criteria. 

4. Execute report. 
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Re-Prompt Feature 

This feature allows you to modify your prompt selections in order to re-run a report. 

To use the re-prompt feature, select Re-Prompt from the Data menu or click the re-prompt button.   

The first prompt for the report will appear, and you can change any of your selections prior to re-executing the 
report.  

 
If you have drilled in the report, the re-prompt feature will not be available. 

Note:  Once you re-prompt a report, your newly generated report will replace the old report in your History folder.  

 

Concurrent Reporting Feature 

This feature allows a user to execute multiple reports at the same time.  A user can begin one report and can go 
back and create another report while the first report is being built.  All reports will be available via the user’s History 
List upon completion. 
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How Do I Customize Report Data? 
Data Pivoting 

You can use this feature to rearrange the columns and rows in your report so that you can view the data from 
different perspectives. 

To use data pivoting, select Show Pivot Buttons from the View menu.  Data pivoting buttons will appear on your 
grid, and you can use them to rearrange your columns and rows. 

 
These pivot buttons will appear on your report:  

 Page By—Move this column to the Page By table 

 Move to Rows—Change this column to a row in the report 

 Move to Columns—Change this row to a column in the report 

  Move Left/Move Right—Shift this column horizontally 

  Sort Data—Arrange column data in ascending or descending order 
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Page-By 

You can use this feature to select and display subsets of your data as separate pages.  This is most useful for 
extremely long reports.  

To create page-by fields on a report, drag and drop the header of the column(s) by which you want to separate your 
pages into the Page By panel.  You can place more than one object in the Page By field.  

Use the drop-down menu to select the specific data you wish to see on the page.  

  

 
Note:  You can place more than one attribute in the Page By panel.  The order of the objects in this panel can 
influence the list of elements displayed for subsequent columns that you add to the Page By panel.  
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Sort Feature 

You can use this feature to sort your data in ascending or descending order. 

To sort your data, select Sort from the Data menu.  In the Sort panel, select your desired sorting attributes from the 
Sort By drop-down menu, then select the Ascending or Descending radio button.  Repeat this process for the Then 
By fields, and click Apply.  

 
 

Quick Sort 

You can also quick-sort columns by right-clicking on the header and selecting Sort > Ascending or Descending. 
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Totals Feature 

You can use this feature to reflect accumulations at selected attribute levels.  There are various totals available, 
such as count, minimum, maximum, standard deviation, etc.  

To display totals on a report, select Totals from the Data menu, then select the desired category of Totals from the 
list.  Select Subtotal or Grand Totals Only for the type of total you choose.  

 

 
Note:  If your report has only one attribute, Subtotals and Grand Totals will produce the same result since totals are 
calculated across levels in you report.   
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How Do I Drill In My Report? 
Drilling  

Drilling allows you to see data at levels other than that of an original report.  It allows you to quickly and easily 
investigate the data in your report.  

Available drilling options include: 

1. Left-Click and Right-Click Drill:  Allows a user to quickly drill on data elements and attributes within the 
hierarchies that are present on the report 

2. Simple Drill:  Allows a user to drill on attributes within the hierarchies that are present on a report 

3. Advanced Drill:  Allows a user to drill on attributes within hierarchies that are not present on the report 

 

Option 1:  Left-Click and Right-Click Drill 

Left-click on a hyperlinked element in your report to drill down one level, or right-click on a hyperlinked element in 
your report to display a pop-up menu from which you can select a drill level.  The resulting data set will be filtered 
with only data for the element you select. 

 
 

You may also right-click on a header in your report to display a pop-up menu from which you can select a drill level.  
In this case, your data set will not be filtered, and will include all values found underneath the header you select. 
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Option 2:  Simple Drill  

You can use this feature to drill in a similar manner to the right-click drill methods, within the hierarchies displayed 
on your report.  

To display the Simple Drill panel, select Drill from the Data menu.   

 
Select the level to which you want to drill in the To drop-down menus, and click the Go button to display your report.  
Check the boxes of the rows on which you want to drill. 
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Option 3:  Advanced Drill  

You can use this feature to drill to a completely different hierarchy than those currently included in the report.  

To display the Advanced Drill panel, right-click on your report and select Drill > More Options. 

 
Select the hierarchy in which you want to drill from the list in the Select Hierarchy box, then select the hierarchy 
level to which you want to drill in the To Hierarchy drop-down menu.  Click the Go button to display your report.  
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How Do I Save Reports? 
Save Report 

To save your report, select Save As from the Report menu or click the Save button.  The Save Report window will 
appear; type a name and description for your report in the Save Report As: and Description boxes, and click Save.    

  
You have the following options when saving your report:  Save report in Report format (prompt selections cannot be 
changed), save report in Prompt format (prompt selections can be changed), and save report with all the embedded 
prompts. 

 
Your report will be saved to the My Reports folder.  After saving, be sure to delete your report from the History 
folder.  There are a maximum number of 25 reports that can be kept in the History folder so it is good practice to 
periodically clean out any unused reports from the History folder. 
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Delete Saved Reports 

To delete your report from the My Reports folder, select the My Reports tab and click the Delete report link for the 
report that you wish to delete.    

 
Click Delete again on the Delete Confirmation screen, and your report is permanently deleted from the My Reports 
folder.  
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How Do I Use Saved Reports? 
All of your saved reports are placed in the My Reports folder.  You can access reports that have been saved to the 
My Reports folder by clicking on the My Reports tab and clicking the link of the report that you wish to view. 
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How Do I Export Reports? 
Export Report to Excel 

To export your report to Excel, select Export from the Report menu or click the export button.   

 
You will be asked whether you want to open the report immediately or save it; make your selection and click the 
appropriate button.  

 
 

Clicking Open will open your report in Excel format in a pop-up window.  You may then make any modifications and 
save your report.  

Clicking Save will open a pop-up window and you can save your report without opening it. 
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Portable Document Format (PDF) Feature 

This feature allows you to export your report to Portable Document Format (PDF), which makes it a read-only file.  
To export your report to PDF, select PDF from the Report menu or click the PDF button.  

 
Note:  To view PDF files, you must have Adobe’s Acrobat Reader software (version 4 or greater) installed on your 
computer.  
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How Do I Print Reports? 
To print your report, select Print from the Report menu or click the print button.  A pop-up Print Options window will 
appear; verify your print options and click Print. 

 
 
Your selections will print on the first page and your report will follow. 
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Where Can I Get Help? 
Help Folder 

To access the Help folder, click the Help link on the Home page.  A separate browser window will launch, and you 
will be able to search for help topics using the three tabs (Index, Contents and FAQs) at the top of the screen.  Use 
the Index tab for alphabetical searching, the Contents tab for topical searching, or the FAQs tab for Frequently 
Asked Questions.  

 
 

Context Sensitive Help 

The Context Sensitive Help buttons allow direct access to the section of the Online Help menu that is specific to the 
action being performed by the user.   Users can click the question mark button to view the Online Help Window for 
feature selected.  To return to the report, users will close the Online Help window by clicking the X.  
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National Customer Support Center  

If you need help or have questions about your account or registration process, please contact Customer Support at 
1-800-238-3150 (Mon – Fri 7:00 AM – 5:00 PM Central) or forward an email to incsc@usps.gov. 

If you have questions or comments about the Product Performance reports forward an email to: 
rfisher1@email.usps.gov. 
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